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What to visualize..?

The structure (unit cell, positions of atoms)

Charge (spin) density ρ(r), or “local density of states”:
properties on the grid

Kohn-Sham orbitals: properties expanded over the basis functions

Fermi surfaces (or other isoenergy surfaces in k-space)

Molecular dynamics or relaxation: how the atoms move (a movie)

Phonon vibration modes (after a Vibra/vibrator run), shown by
arrows or as a movie
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What to visualize..?

Atomic structure

The error-free choice of structure (unit cell,
positions of atoms) is the full responsibility
is on the user; only minimal checks are done
by Siesta (e.g., “atoms too close”).

Since the input format is quite flexible (a big advantage!), it is difficult to
organize a simple viewer of input structure data, without using the fdf
routines. However, the .XV file (created after the completion of electronic
structure loop) contains all necessary information, as it was really
understood by Siesta, in a fixed format: unit cell vectors and atom
coordinates, all in Bohr. This file can be easily transformed to, e.g. .xyz
format which is read by many vizualization programs (xmakemol, ...).

In the following examples, we’ll use XCrySDen.
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What to visualize..?

Charge/spin density; local density of states

These are scalar fields available, after a Siesta
run, on a 3-dim. mesh (the number of divi-
sions along three lattice vectors is governed by
the MeshCutoff parameter). A typical graphi-
cal representation of such scalar fields is by con-
tour plots in 2-dim. cutting planes, and/or iso-
surfaces of a given level. Both representations are possible with XCrySDen.

Kohn-Sham wavefunctions

These are also scalar functions of spatial coordinates, but obtained in
Siesta as expansions over the basis functions. Their visual representation
(as 2-dim. contours in a chosen plane, or 3-dim. isosurfaces) is handled by
the denchar code. The denchar allows export of data in the Gaussian
cube format, which can be read in by XCrySDen.
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What to visualize..?

Fermi surfaces

can be calculated using the energy dispersion data E (k), available from
any band structure code. The difficulty of purely technical character is,
how to construct energy isosurfaces and conveniently manipulate them (to
choose viewpoint, select different sheets of the Fermi surface, etc.) This
job is done within XCrySDen, provided the E (k) data are passed in a right
format.
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What to visualize..?

Molecular dynamics or relaxation

runs store the atomic positions in .MD and/or .ANI files (with and without
unit cell information, correspondingly). Such sequences of atomic positions
can be animated using various software packages, including XCrySDen.

Phonon modes

from Vibra/vibrator calculation after a

MD.TypeOfRun FC

Siesta run can be represented by arrows
(in a static figure), or as animations (a
sequence of vibration snapshots).
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XCrySDen by Tone Kokalj, http://www.xcrysden.org

A powerful, flexible, stable, free-to-use,
open-source software
for different visualizations.
Runs under XWindows and on the Mac.
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It enables different presentations
of atoms and bonds (colors, shadows, ...),
measuring distances and angles ...
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... allows to set arrows on atoms
(or, on fictituous atoms)
and make animations ...
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... allows to make contour plots,
to draw isosurfaces,
to choose path through the Brillouin zone,
to use different modi
of presenting the Fermi surfaces
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Format of XCrySDen input files (.xsf, .axsf, .bxsf)

A clear and well documented
human-readable input format...
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Format of XCrySDen input files (.xsf, .axsf, .bxsf)

... including forces
(or, velocities)
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Format of XCrySDen input files (.xsf, .axsf, .bxsf)

... and animations for molecular
and periodic structures
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Sies2xsf utilities

Where to find them:

· · · siesta-2.0/Util/Contrib/APostnikov/ (old!)

http://www.home.uni-osnabrueck.de/apostnik/Downloads ,
or mailto apostnik@uos.de or postnikov@univ-metz.fr

What do they make out of what:

xv2xsf: .XV → .XSF (view structure + cell)

rho2xsf: .XV, .RHO or .LDOS → .XSF
(atoms within a selected box + data grids)

md2axsf: .XV, .ANI or .MD → .AXSF
(animations of structure with fixed or variable cell)

eig2bxsf: .XV, .KP and .EIG → .BXSF (Fermi surfaces)

vib2xsf: .XV and .vectors → .XSF and .AXSF
for each selected phonon mode; static (with arrows to indicate
dilacement patterns) and dynamic (animated phonon).
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Visualization of atomic positions

xv2xsf asks for a .XV file and transforms it into .XSCF

I know my structure already, why visualize it? → two reasons:

1. xv2xsf uses .XV file, i.e. the structure information as is was understood
by Siesta, including possible input errors (messed up units etc.)
2. xv2xsf allows to draw the simulation cell, which is useful in case of
molecules or slabs: is there enough space around? Is it not too much?

Note: XCrySDen draws all atoms inside the simulation box, irrespectively
of their given positions. So you might want to see replicated cells ...

⇒
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Visualization of atomic positions

Example of for a crystal of Fe-binuclear units:

Xmakemol

XCrySDen

This is “Lighting Off” mode of XCrySDen:
no shadows or isosurfaces, but fast mani-
pulations with a structure, and possibilty of
vectorial PostScript optput.
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Visualization of atomic positions

An unexpected bonus for Siesta users:
XCrySDen constructs the Brillouin zone
from structure information in the .XCF file
and allows to select k-path for plotting
band structurse. Go to

Tools → k-path Selection

SnO2 (rutile structure)
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Putting arrows on atoms

Suppose we have local (e.g., non-collinear) magnetic moments. Can we
show them with XCrySDen?
→ Yes, we can use “Forces” entry in the XCrySDen input file format,
columns #5 – 7. (But, there is no special tool for this. You should do it
by hand, or write your own script). An example:
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Putting arrows on atoms

Suppose we have local (e.g., non-collinear) magnetic moments. Can we
show them with XCrySDen?
→ Yes, we can use “Forces” entry in the XCrySDen input file format,
columns #5 – 7. (But, there is no special tool for this. You should do it
by hand, or write your own script). An example:

After opening this .XSF file,
do not forget to activate
Display → Forces,
and optionally do
Modify → Force settings

An icosahedral Co13 cluster
with non-collinear setting of spin moments
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Putting arrows where there are no atoms

XCrySDen allows to declare ghost atoms,
labeled ’X’. They can be set very close
to other atoms, so that XCrySDen won’t
complain – even at exactly the same place.
The ghost atoms may have any radius, e.g.
zero, and yet carry arrows.

One can make quite diferent use of such
arrows. The only limitation: the proper-
ties of all arrows are fixed by

Modify → Force settings

and cannot be diversified.
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Visualization of Charge/spin densities, or of LDOS

1 An input file for XCrySDen is created by rho2xsf.

2 Accept the same approach as in Denchar: define the output box (by
origin point and three spanning vectors, not necessarily orthogonal)
and grid size along each grid direction. The values of a Siesta
property defned on the internal Siesta grid are (linearly) interpolated
onto the grid of the output box.

3 The output box may be also 2-dimensional
(No. of divisions =1 along one spanning vector).

4 The output box may coincide with the Siesta box, or not.
XCrySDen can apply translations to to generated grid.

5 Choice isosurface parameters, cutting planes, isolines on the cutting
planes, colors, lighting etc. from the means of XCrySDen.
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Visualization of Charge/spin densities, or of LDOS

Start rho2xsf from a console
and type in the answers
(marked in red)
to the queries set by the system
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Visualization of Charge/spin densities, or of LDOS

A linear interpolation
(over the four nearest points)
from the Siesta real-space grid
onto the visualization grid
for XCrySDen

• The fineness of the visualization is limited by the sparciest one of the two grids.
• The cutting planes in XcrySDen may only be those of the visualization grid.
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Plotting of grid properties

Loading the .XSF file

File → Open Structure → Open XSF

shows the atoms
within the visualization box.

This is a cut
out of molecular crystal
formed by Fe-binuclear units
(shown earlier)
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Plotting of grid properties

For loading a grid property
(RHO), go to

Tools → Data Grid

and set the weights
of the different subblocks.
In a spin-polarized case,
there are two.
Choose 1.0 and 1.0
for plotting the charge density,
1.0 and −1.0
for plotting the spin density,
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Plotting of grid properties

Set the isovalue to plot the surface,
and press “Submit”
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Plotting of grid properties

Here is the charge density.
It is cut at the edges of the
visualization box.
COLOR and TRANSPRENCY
parameters can be adjusted
within broad limits.
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Plotting of grid properties

Similar, for the spin density
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Plotting of grid properties

Similar, with isolines in a cut-
ting plane. Cutting planes
can only pass parallel to the
edges of the visualization box.
Therefore, the initial choice
of the box (as rendered by
rho2xsf) is important for a
physically meaningful visuali-
zation.
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Visualization of Wave Functions

In principle, Denchar does this job quite fine. However, we’d like to have
an interface to XCrySDen. To this end:

1 Use Denchar, define output box there, save result as Gaussian98
Cube file.

2 Read this Gausian98 Cube file into XCrySDen. Save in the XCrySDen
format .xsf ( → A).

3 A bug (or a feature?) in Denchar: it correctly translates the WF
images (grid) over the output box, but not atoms.

4 How to fix: run rho2xsf, define the same output box as in Denchar.
Save the atom part in the XCrySDen format .xsf ( → B).

5 Insert (by hand) the “correct” atom part from (B)
into the place of “incomplete” atom part from (A).

6 If needed, merge many grid blocks (which reside in different .xsf files,
each exported from its own Gausian Cube) into a single .xsf file.

A.Postnikov (Université Metz) Vizualization and post-processing tools June 2007 13 / 23



The rest goes exactly as
with the charge density.
This example is for a frag-
ment of a heterospin poly-
mer (Cu ion in the com-
plex with hexafluoroacetyl-
acetonate, flanked by two
free radicals).
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one orbital...
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... another orbital,
in combination with two
cutting planes
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Visualization of Fermi surfaces

1 Calculate eigenvalues on a sufficiently fine,
undicplaced k-mesh, i.e.

%block kgrid Monkhorst Pack
16 0 0 0.
0 16 0 0.
0 0 16 0.

%endblock kgrid Monkhorst Pack

2 get files .XV, .KP, .EIG,
run eig2bxsf → creates .BXSF
(or .BXSF 1 and .BXSF 2
for spin-polarized case).
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Visualization of Fermi surfaces

in XCrySDen, choose
File → Open Structure → Open BXSF
In the window that pops up,
specify the Fermi energy
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Visualization of Fermi surfaces

See which bands cross the Fermi energy,
and select which of them you want to plot
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Fermi surfaces of some elemental metals

Na
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Fermi surfaces of some elemental metals

Na
Al
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Fermi surfaces of some elemental metals

Na
Al Y
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Fermi surface of MgB2

over the reciprocal cell

over the Brillouin zone
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Molecular Dynamics or Relaxation

1 Calculate MD history:
WriteMDhistory T
writes (updates existing) unformatted .MD file,
either with or without variable cell;
WriteMDXmol T
writes (updates existing) formatted .ANI file
(coordinates only, no variable cell information).

2 Having .XV, and either .MD, or .ANI
run md2axsf, answering questions about the (optional) choice of output box
and the MD steps to visualize (first #; last #; keep only each #’s)
→ creates .AXSF.

Hopefully, variable or fixed cell will be recognized automatically.
If cell information from .MD is not available, the .XV will be used
(assuming fixed cell).
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In order to see many unit cells,
go to Modify → Number of Units drawn

This is graphite (4 at./cell)
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Opening .AXSF file pops up
the Animation Control Center
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Choosing “Animated GIF/MPEG”
opens menu with animation options
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... and saved!
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Frozen phonons (zone-center only)

1 get .vectors (calculated by vibrator) and .XV (from Siesta)

2 run vib2xsf, select # modes (first ... last) to vizualize. For each
selected mode, a separate .XSF file and an .AXSF file are created.
.XSF contains a static structures (as in .XV), with arrors added to
each atom to indicate displacement pattern.
.AXSF contains the animation of a phonon, for a (user-chosen)
amplitude and number of steps.
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An example of phonons in In- and N-doped GaAs

In order to show
vibrations patterns as arrows:
1. Select Display → Forces;
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An example of phonons in In- and N-doped GaAs

In order to show
vibrations patterns as arrows:
1. Select Display → Forces;
2. Most probably, you would need
to change Modify → Force settings,

In order to show
vibrations patterns as arrows:
1. Select Display → Forces;
2. Most probably, you would need
to change Modify → Force settings:
change Scale Function: linear,
(increase) Length factor,
change vectors attributes.
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An example of phonons in In- and N-doped GaAs

One of N-related modes.
The atoms shown are cut from
much bigger supercell by selecting
the “visualization box” in vib2xsf,
and then some more atoms have been
removed by hand.
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Concluding remarks and known limitations

XCrySDen allows to manage (almost) all structure-related results
from a Siesta calcultion I can think about... do you have any other
suggestions? It is a great software (both, I mean).

The final results are bitmap (or, other format) damps of the contents
of the simulation window (in the full-screen mode if needed), that
would normally suffice for publication/presentation purposes. Atomic
structure (atoms, bonds and cells, but not grid properties) can also be
stored in [ Display → Lighting off ] mode as a postscript vector
graphics.
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Concluding remarks and known limitations

What is missing in XCrySDen is an option to paint an isosurface /
Fermi surface with a property (e.g., Fermi velocity).

Fermi-surface part of XCrySDen is not as flexible as real-space-grids
part in what regards choosing view frame, colours, light sources etc.

Making 2-dim. cuts of the Fermi surface is not implemented.
However, this can be easily done by exporting the E (k) data ordered
by the eig2bxsf script to other plotting routine.

A possible extension: representing a vector field – e.g., the
magnetization m(r) from a non-collinear spin calculation. XCrySDen
allows to draw a forest of arrors (“forces”) stuck to ghost atoms of
chemical label ’X’, which atoms won’t be visible if their radii set to
almost zero, but arrors well visible is thick enough.
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